PressPage Newsrooms logo

Incident

Outage of Newsrooms Platform

Resolved | Dec 20, 2020 | 23:00 GMT+01:00

Resolved - Between 2020-12-19 11:07:53 CEST to 2020-12-19 11:13:30 (5 mins 37 secs), we experienced a brief outage of our Newsrooms Platform.

We have identified the root cause and are implementing measures to prevent recurrence.

Status Page powered by Admin Labs