Presspage Newsrooms logo

Incident

Outage of platform

Resolved | Jan 31, 2023 | 10:15 GMT+01:00

We've experienced a short outage of the Presspage platform. Immediate action was taken to address the issues, resulting in the Newsrooms and our Manager tool being quickly available again. We have identified the root cause and are implementing measures to prevent recurrence.

Investigating | Jan 31, 2023 | 10:10 GMT+01:00

We are experiencing an outage of the PressPage platform. Our teams are working hard to get this resolved as soon as possible

Status Page powered by Admin Labs